Разработка технической документации и технические писатели Технические писатели и разработка технической документации технические писатели в Телеграм 

 obmen_soobsheniyami.png Чат для технических писателей 
 Зарегистрируйтесь
Страницы: 1
RSS
HM2Go, Мини сервер для локальной WebHelp
 
Уважаемые форумчане, кто-нибудь пробовал что такое HM2Go?
В хелпе к 6 версии вроде бы все понятно, но пробую, а ничего не получается.
Если я правильно понимаю, то через HM2Go Google Chrome не будет жаловаться и выдавать всякие сообщения подобного рода:
 
HM2Go запускается автоматически при открытии скомпилированной Webhelp-справки после публикации. В области уведомлений появляется значок сервера HM2Go и справка работает через него (http://127.0.0.1/E:/Project/HTML/index.html?topic.htm). Дополнительных настроек и запуска не требует и предназначен для проверки скомпилированных проектов. Когда запущен, при желании можно проверить и настроить (http://127.0.0.1/:config).
 
Цитата
H&M User написал:
HM2Go запускается автоматически при открытии скомпилированной Webhelp-справки после публикации. В области уведомлений появляется значок сервера HM2Go и справка работает через него (http://127.0.0.1/E:/Project/HTML/index.html?topic.htm). Дополнительных настроек и запуска не требует и предназначен для проверки скомпилированных проектов. Когда запущен, при желании можно проверить и настроить (http://127.0.0.1/:config).
Обе ссылки у меня не открываются.
В HM2Go конфигурациях я пробовала выставить порт так, как это прописано в хелп-справке H&M 6.


После компиляции страница браузера все равно стартует с единственной строчкой: "Status 400:Bad Request"
 
Первая ссылка ведет на мой проект на диске E:\ и если там у Вас нет ничего подобного, то ничего не откроется.
Вторая ссылка должна работать при запущенном HM2Go сервере обязательно, но если Вы изменили порт на 8810, то ссылки должны принимать вид http://127.0.0.1:8810/
Порт следует изменять только в том случае, если у Вас уже локально установлен другой web-сервер (напр. IIS) и порт занят. H&M по умолчанию запускает скомпилированные справки на 80 порт (который не указывается, т.к. используется по-умолчанию).
Запускать скомпилированные страницы вручную можно одним из способов:
1) Выполнить открытие страницы из HM2Go


2) Выполнить в командной строке HM2GO.EXE /P:8810  /T:0 /PRJ:index.html или создать bat- или cmd-файл
Код
@echo off
start /B HM2GO.EXE /P:8810 /T:0 /PRJ:index.html

3) Запускать напрямую в браузере при запущенном HM2Go http://127.0.0.1:8810/index.html?introduction.htm#begin

4) При поставке справочной системы на CD или DVD, скопировать HM2Go.exe на диск и создать файл autorun.inf
Код
[autorun]
open=HM2GO.EXE /P:8810 /T:0 /PRJ:index.html
icon=ваша_иконка.ico
Изменено: H&M User - 26.08.2015 14:33:00
 
H&M User,
ничего не понимаю. Не работает и все тут.

Мои действия по шагам:
1) Настраиваю порт, сейчас выглядит он вот так:

2) Компилирую свой проект на локальном диске. Сервера у меня дома нет.
3) После компиляции файл проекта автозапускается с помощью HM2Go и я должна видеть свой проект.
Я вижу это (браузер Mozilla Firefox):
 
К сожалению, мозиллы нет, только Edge и IE. Устанавливаю 8810 - на них все работает. Попробуйте запустить свой проект в другом браузере. И еще - попробуйте сохранить свой проект в другой папке.
Edge:

IE:
 
 
Цитата
H&M User написал:
Попробуйте запустить свой проект в другом браузере.
Попробовала, сделать Google Chrome браузером по умолчанию - одинаково, что Chrome что Mozilla.
Цитата
H&M User написал:
И еще - попробуйте сохранить свой проект в другой папке.
а чем ему папка на английском языке не нравится???

О...вопрос такой, а может ли как то влиять на все это то, что HM2Go в свое время был установлен кажется по-моему отдельной утилиткой для 5 версии H&M (она устанавливалась в каталог самой папки EC Software по умолчанию). А еще также при установке H&M 6 (она тоже в его папке имеется) и теперь в H&M 7 она 3 раз?
Просто я уже не знаю, что еще предположить, почему программа практически без каких-либо настроек у всех работает, а у меня почему то нет. wall-smile
Изменено: alex23 - 27.08.2015 15:54:48
 
Кажется моя проблема решилась.
Все как всегда оказалось банально, причина тому каталог на русском языке. Снова проблема с кириллицей, не любит H&M русские буквы, печально. :cry:
 
Цитата
alex23 написал:
Снова проблема с кириллицей
При возникновении любой проблемы - это первое, что следует проверять, как показывает практика :D
Изменено: H&M User - 27.08.2015 16:51:01
Страницы: 1
Читают тему